Вопрос по информатике:
1) Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел. Использовать цикл repeat.
2) Напишите программу, которая выводит на экран таблицу умножения на N, чисел от 0 до 10.
Помогите пожалуйста!(
- 06.01.2016 03:32
- Информатика
- remove_red_eye 11158
- thumb_up 51
Ответы и объяснения 1
Program n1;
var a,i,p,sum: integer;
begin
sum:=0;
p:=1;
repeat
readln(a);
if a>0 then sum:=sum+a;
if a<0 then p:=p*a;
until (a=0);
writeln('произведение отрицательных: ',p);
writeln('сумма положительных: ',sum);
end.
2)
Program n2;
var n,i:integer;
begin
write('Введите n = ');
readln(n);
writeln('Таблица умножения числа ', n);
for i:=0 to 10 do
writeln(n,'*',i,'=',n*i)
end.
- 07.01.2016 19:11
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.