Вопрос по информатике:
Напишите программу(Pascal)
Найдите сумму всех вводимых с клавиатуры чисел, кратных заданному числу а.
- 17.05.2018 01:58
- Информатика
- remove_red_eye 5317
- thumb_up 19
Ответы и объяснения 2
var sum,a,c: integer;
begin
readln(a);
sum:=0;
while true do
begin
readln(c);
if c=0 then break;
if c mod a=0 then sum:=sum+c;
end;
writeln(sum);
end.
- 18.05.2018 11:33
- thumb_up 7
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadInteger('a=');
Writeln(ReadSeqIntegerWhile(x->x0).Where(x->x mod a=0).Sum)
end.
Пример
a= 2
5 7 12 8 -4 3 11 0
16
- 19.05.2018 06:55
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.