Вопрос по информатике:
1)Дана строка символов среди которых есть двоеточие (:)определите сколько символов ему предшествует.
2)дана строка слов В. Сформулируйте литерную величину А, состоящию из первых букв слов входящих в строку В.
3)Дана строка состояща я из нескольких слов .найдите наибольшую длину слова.
4()в записке слова зашифрованы каждое из них записано на оборот ,расшифруйте сообщение .
- 26.07.2018 03:03
- Информатика
- remove_red_eye 12323
- thumb_up 46
Ответы и объяснения 1
1.
begin
write(ReadString.indexof(':'))
end.
Пример ввода: 1234:56
Пример вывода: 4
2.
begin
write(readString.ToWords.Select(x->x[1]).JoinIntoString)
end.
Пример ввода: Как любила язвить королева, собаки апплодировали
Пример вывода: Клякса
3.
begin
write(readString.ToWords.Select(s->Length(s)).Max)
end.
Пример ввода: Не хочу учиться хочу жениться
Пример вывода: 8
4.
Если там нет знаков препинания:
begin
write(readString.ToWords.Select(s->ReverseString(s)).JoinIntoString(' '))
end.
Если там есть знаки препинания, которые надо оставить на месте, то настолько же короткого решения мне не придумалось, можно так:
begin
var str := readString + ' ';
var m := '';
for var i := 1 to str.Length do
if str[i].IsLetter then
m += str[i]
else
begin
write(ReverseString(m), str[i]);
m := '';
end;
end.
Пример ввода: амар алым умам
Пример вывода: рама мыла маму
- 27.07.2018 08:37
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.