Вопрос по информатике:
Составить программу вычисления значений функции F(x) на отрезке [a;b] с шагом h. Результат представить в виде таблицы
F(x)=корень из х*соs^2x
- 13.03.2018 02:51
- Информатика
- remove_red_eye 8336
- thumb_up 16
Ответы и объяснения 1
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a,b,h:real;
Write('Введите a,b,h: '); Read(a,b,h);
var n:=Trunc((b-a)/h);
for var i:=0 to n do begin
var x:=a+i*h;
var y:=cos(x)*sqrt(x);
Writeln(x:6:3,y:15:5)
end
end.
Пример
Введите a,b,h: 0.2 3.2 0.3
0.200 0.43830
0.500 0.62054
0.800 0.62315
1.100 0.47574
1.400 0.20111
1.700 -0.16799
2.000 -0.58852
2.300 -1.01046
2.600 -1.38169
2.900 -1.65348
3.200 -1.78580
- 14.03.2018 15:04
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.