Вопрос по информатике:
Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
На языке СИ
- 17.08.2018 21:28
- Информатика
- remove_red_eye 19028
- thumb_up 20
Ответы и объяснения 1
#include #include #include
int main() { setlocale(LC_ALL, "");
int a, b, c = 0;
std::cout <> a; std::cout <> b;
if (b != abs(b)) { a = -a; b = abs(b);//функция которая возвращает модуль переданного числа }
for (int i = 0; i < b; ++i) { c += a; }
std::cout << "num:" << c;
system("pause"); return 0;}
- 18.08.2018 12:43
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.