Вопрос по информатике:
Написать программу, которая проверяет, является ли четным введенное пользователем целое трехзначное число число.
- 22.12.2017 18:54
- Информатика
- remove_red_eye 1432
- thumb_up 28
Ответы и объяснения 1
Путь решения: сохраняем в переменную введенное пользователем число, например в a получаем остаток деления на 2 и сравнимаем с 0. Если равен, то число - четное иначе не четное.
P.S. Так как число a используется в программе меньше или равно 1 раз, то это число можно не сохранять, а сразу работать с ним, в месте вызова функции.
Используемые языки: Pacal, Python, JavaScript
Язык: Pascal
//fpc 3.0.0
Var
a:integer;
Begin
read(a);
if (a mod 2 = 0) then write('Введенное число четное')
else write('Введенное число нечетное');
End.
ИЛИ
//PascalABC.NET (версия 3.2, сборка 1363)
Begin
print(ReadInteger() mod 2 = 0 ? 'Введенное число четное' : 'Введенное число нечетное')
End.
Язык: Python
print('Введенное число ' + ('нечетное', 'четное')[int(input()) % 2 == 0])
Язык: JavaScript
alert('Введенное число ' + (Number(prompt()) % 2 === 0 ? 'четное': 'нечетное'));
- 23.12.2017 21:00
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.