Вопрос по информатике:
Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры. Если есть, то вывести эти элементы
- 06.04.2015 15:53
- Информатика
- remove_red_eye 10113
- thumb_up 7
Ответы и объяснения 1
const n=17;
var a: array[1..n] of integer;
i,c,k: integer;
begin
randomize;
write('введите число: ');
readln(c);
writeln('массив: ');
for i:=1 to n do
begin
a[i]:=random(50);
write(a[i],' ');
end;
writeln;
writeln('эл. которые меньше ',c);
for i:=1 to n do if a[i]
k:=k+1;
write(a[i],' ');
end;
writeln;
writeln('количество: ',k);
end.
- 07.04.2015 23:15
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.