Вопрос по информатике:
1) Написать программу в паскале, "проверить, являются ли цифры введенного трехзначного числа возрастающей последовательностью"
2) Написать программу в паскале, "по введенным координатам точки (х,у) определить в какую четверть попадает эта точка"
- 11.05.2018 06:21
- Информатика
- remove_red_eye 18786
- thumb_up 24
Ответы и объяснения 2
Program n1;
var n:integer;
begin
write('Введите 3-х значное число: ');
readln(n);
if ((n div 100 < n div 10 mod 10) and (n div 10 mod 10 < n mod 10)) then
writeln('true')
else writeln('false');
end.
2)
Program n2;
var x,y: real;
begin
readln(x,y);
if(x=0) and (y=0) then writeln('точка в начале координат')
else if(x>0)and(y>0) then writeln('I четверть')
else if(x0) then writeln('II четверть')
else if(x<0)and(y<0) then writeln('III четверть')
else if(x>0)and(y<0) then writeln('IV четверть')
else if(x=0)and(y0) then writeln('точка на оси OY')
else if(x0)and(y=0) then writeln('точка на оси OX');
end.
- 13.05.2018 00:20
- thumb_up 47
// Внимание! Если программа не работает, обновите версию!
№1
begin
var s:=ReadInteger.ToString;
if s=s.Distinct.Sorted.JoinIntoString('') then
Writeln('Цифры являются возрастающей последовательностью')
else
Writeln('Цифры не являются возрастающей последовательностью')
end.
Примеры
148
Цифры являются возрастающей последовательностью
355
Цифры не являются возрастающей последовательностью
№2
begin
var x,y:real;
Write('Введите координаты точки: '); Read(x,y);
if x*y=0 then Writeln('Нули вводить не допускается')
else
if x*y>0 then
if x>0 then Writeln('I четверть')
else Writeln('III четверть')
else
if x>0 then Writeln('IV четверть')
else Writeln('II четверть')
end.
Пример
Введите координаты точки: -2 -3.2
III четверть
- 13.05.2018 06:36
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.