Вопрос по информатике:
PASCAL ABCНапишите программу, которая определяет правильность записи целого числа в восьмеричной системе счисления.
Формат входных данных
На вход программы поступает символьная строка.
Формат выходных данных
Программа должна вывести ответ 'YES', если строка представляет собой правильную запись целого числа в восьмеричной системе счисления, и 'NO', если запись ошибочна.
- 20.08.2016 11:42
- Информатика
- remove_red_eye 7983
- thumb_up 27
Ответы и объяснения 1
begin
var s:=readstring ('Введите строку: ');
val (s, value, error);
if (error0) or ('9' in s) or ('8' in s) then write ('NO') else write ('YES');
end.
- 21.08.2016 15:47
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.