Вопрос по информатике:
Написать программу определения стоимости разговора по телефону с учётом скидки 20%, предоставляемой по субботам и воскресеньям. Входные данные: Sm(стоимость минуты разговора), M (число минут), Day (день недели - 1...7). Выходные данные: S (стоимость разговора). Ниже представлен вариант выполнения программы Вычисление стоимости телефонного разговора Введите исходные данные Стоимость минуты разговора, руб. 1 Длительность разговора (целое количество минут) 6 День недели (1-понедельник, ... 7-воскресенье) 7
- 17.05.2018 05:07
- Информатика
- remove_red_eye 14678
- thumb_up 46
Ответы и объяснения 1
begin
writeln('Вычисление стоимости телефонного разговора');
writeln('Введите исходные данные');
write('Стоимость минуты разговора, руб. ');
readln(Sm);
write('Длительность разговора (целое количество минут) ');
readln(M);
write('День недели (1-понедельник, ... 7-воскресенье) ');
readln(Day);
S:=Sm*M;
if (Day=6)or(Day=7)
then writeln('Стоимость разговора с учетом скидки = ',S*0.8)
else writeln('Стоимость разговора = ',S);
end.
Пример:
Вычисление стоимости телефонного разговора
Введите исходные данные
Стоимость минуты разговора, руб. 3.2
Длительность разговора (целое количество минут) 6
День недели (1-понедельник, ... 7-воскресенье) 7
Стоимость разговора с учетом скидки = 15.36
- 18.05.2018 22:27
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.