Вопрос по информатике:
1. Даны два ненулевых числа а и b. Напишите программу для нахождения суммы, разности, произведения и частного.
2. Напишите программу для нахождение периметра и площади прямоугольного треугольника, если даны длины его катетов а и b.
3. Ввести трехзначное число a. Напишите программу которая поменяет крайние цифры числа местами.
- 19.08.2018 01:09
- Информатика
- remove_red_eye 19742
- thumb_up 40
Ответы и объяснения 1
Program n1;
var a,b: real;
begin
readln(a,b);
writeln('разность: ',a-b);
writeln('произведение: ',a*b);
writeln('сумма: ',a+b);
writeln('частное: ',a/b);
end.
2)
Program n2;
var a,b,c: real;
begin
readln(a,b);
c:=sqrt(a*a+b*b);
writeln('площадь: ',0.5*a*b);
writeln('периметр: ',a+b+c);
end.
3)
Program n3;
var d1,d2,d3,a: integer;
begin
write('введите число: ');
readln(a);
d1:= a div 100;
d2:=a div 10 mod 10;
d3:=a mod 10;
writeln(d3,d2,d1);
end.
- 20.08.2018 19:51
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.