Вопрос по информатике:
Известны координаты трех точек. Составить программу нахождения площади треугольника, построенного по этим точкам
ПОМОГИТЕ ПОЖАЛУЙСТА
- 23.05.2017 08:52
- Информатика
- remove_red_eye 10901
- thumb_up 11
Ответы и объяснения 1
var x1,x2,y1,y2,x3,y3,S: real;
begin
write('введите координаты точки А: ');
readln(x1,y1);
write('введите координаты точки B: ');
readln(x2,y2);
write('введите координаты точки C: ');
readln(x3,y3);
S:=0.5*((x1-x3)*(y2-y3)-(x2-x3)*(y1-y3));
writeln('площадь: ',abs(S));
end.
- 24.05.2017 03:30
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.