Вопрос по информатике:
Напишите программу которая производит обмен значений переменных x и y больше y
ВсеВидеоНовостиКартинкиПокупкиЕщё
НастройкиИнструменты
Безопасный поиск включен
- 26.08.2018 12:12
- Информатика
- remove_red_eye 19251
- thumb_up 32
Ответы и объяснения 1
#include
#include
int main(){
setlocale(LC_ALL,"");
int x,y;
std::cout << "Введите x:";
std::cin >> x;
std::cout << "Введите y:";
std::cin >> y;
if (x > y){ /*если x > y то он поменяет их местами*/
std::cout << "x и y поменяны местами\n"
x ^= y;
y ^= x;
x ^= y;
}else{
std::cout << "x и y не поменяны местами\n";
}
std::cout << "x:" << x << " y:" < y;
std::cout << std::endl;
system("pause");
return 0;
}
- 27.08.2018 03:59
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.