Вопрос по информатике:
Написать программу, которая получает на вход число произвольной длины меньше, чем 9 знаков и показывает, какие в нем повторяющиеся цифры
БЫСТРЕЕ!11! Мог не правильно понять вопрос, напишите хоть что-нибудь похожее ,срочно нужно
- 08.09.2015 12:48
- Информатика
- remove_red_eye 18473
- thumb_up 19
Ответы и объяснения 1
var i,n,k: integer;
a: array[0..9] of integer;
begin
write('число: '); readln(n);
for i:=0 to 9 do a[i]:=0;
while n>0 do
begin
k:=n mod 10;
a[k]:=a[k]+1;
n:=n div 10;
end;
for i:=0 to 9 do
if a[i]>1 then writeln('повторяющаяся цифра: ',i);
end.
число: 1022315
повторяющаяся цифра: 1
повторяющаяся цифра: 2
- 09.09.2015 00:42
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.