Вопрос по информатике:
Помогите, пожалуйста Напишите эффективную программу, которая по двум данным натуральным числам a и b, не превосходящим 30000, подсчитывает количество нечетных натуральных чисел на отрезке [a,b] (включая концы отрезка). Программа получает на вход два натуральных числа a и b, при этом гарантируется, что 1 ≤ a ≤ b ≤ 30000. Проверять входные данные на корректность не нужно. Программа должна вывести одно число: количество нечетных чисел на отрезке [a,b].
Пример работы программы:
Входные данные: 11, 21
Выходные данные: 6
- 23.12.2017 19:20
- Информатика
- remove_red_eye 18352
- thumb_up 40
Ответы и объяснения 1
begin
write('a b через пробел: '); readln(a,b);
n:=b-a+1;
if (n mod 2 = 1) and (a mod 2 = 1) then
n:=n div 2 + 1
else n:= n div 2;
writeln('число нечетных чисел: ',n);
end.
- 24.12.2017 19:49
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.