Вопрос по информатике:
Помогите написать программу!!!
Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от -500 до 500 и вводятся с клавиатуры. Найти и вывести:
1. Сумму квадратов отрицательных элементов. Гарантируется, что в исходном массиве есть хотя бы один отрицательный элемент.
2. Произведение элементов массива, имеющих четное значение и стоящих на четных местах. Гарантируется, что в исходном массиве есть хотя бы один такой элемент.
3. Количество элементов массива, превосходящих по модулю 100. Гарантируется, что в исходном массиве есть хотя бы один такой элемент.
- 13.06.2018 13:05
- Информатика
- remove_red_eye 4914
- thumb_up 44
Ответы и объяснения 1
var a: array[1..maxn] of integer;
skv,prod,gr,i: integer;
begin
writeln('введите ',maxn,' чисел');
skv:=0; prod:=1;
gr:=0;
for i:=1 to maxn do
begin
write(i,': '); readln(a[i]);
if a[i]<0 then skv:=skv+a[i]*a[i];
if (a[i] mod 2 = 0) and (i mod 2 = 0) then
prod:=prod*a[i];
if abs(a[i])>100 then gr:=gr+1;
end;
writeln('сумма квадратов отрицательных: ',skv);
writeln('произведение четных на четных местах: ',prod);
writeln('больше 100 по модулю: ',gr);
end.
введите 15 чисел
1: 151
2: -231
3: 104
4: 19
5: 36
6: -112
7: 5
8: 8
9: 11
10: 13
11: 45
12: 5
13: 6
14: 17
15: 19
сумма квадратов отрицательных: 65905
произведение четных на четных местах: -896
больше 100 по модулю: 4
- 14.06.2018 05:46
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.