Вопрос по информатике:
Составить программу, которая подсчитывает количество четных чисел,количество нечетных чисел, сумму и среднее арифметическое в последовательности которая закачивает 0
- 01.01.2015 22:40
- Информатика
- remove_red_eye 19978
- thumb_up 8
Ответы и объяснения 1
var a,kch,knc,k,sum: integer;
begin
write('введите 1 член последовательности: ');
readln(a);
knc:=0;
sum:=0;
kch:=0;
k:=0;
while a0 do begin
k:=k+1;
if a mod 2=0 then kch:=kch+1 else
knc:=knc+1;
sum:=sum+a;
write('введите следущий член: ');
readln(a);
end;
writeln('сумма: ',sum);
writeln('кол-во четных: ',kch);
writeln('кол-во нечетных: ',knc);
writeln('ср. арифмитическое: ',sum/k);
end.
- 02.01.2015 23:31
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.