Вопрос по информатике:
Напишите программу, которая вычисляет факториал натурального числа N ( 1 ≤ N ≤ 10000 ), сохранив все значащие цифры. Факториалом называется произведение всех натуральных чисел от 1 до N : N ! = 1·2·3... ( N - 1)· N .
- 12.11.2017 13:00
- Информатика
- remove_red_eye 11178
- thumb_up 15
Ответы и объяснения 1
var
n, i: integer;
p: real;
begin
write('Введите n: ');
readln(n);
if (n>=1) and (n<=10000) then
begin
p := 1;
for i := 2 to n do
p := p * i;
writeln(n, '! = ', p);
end;
end.
- 13.11.2017 10:13
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.