Вопрос по информатике:
PASCAL ABC NET
ОТМЕЧУ КАК ЛУЧШИЙ ОТВЕТ!!!
Задача 1. Вывести на экран натуральные числа от 1 до 9 в обратном порядке.
Задача 2.
Составить программу вычисления значения выражения y=1+1/2+1/3+... +1/20.
{В данном случае целесообразно организовать цикл с параметром, изменяющимся от 1 до 20, то есть шаг изменения параметра равен +1. Обозначим: у - очередное значение суммы дробей; n - параметр цикла. Учитывая это, составим программу: }
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 17.09.2018 02:34
- Информатика
- remove_red_eye 939
- thumb_up 28
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
№1
begin
Range(9,1,-1).Println
end.
Результат
9 8 7 6 5 4 3 2 1
№2
begin
Writeln('S=',Range(1,20).Aggregate(0.0,(x,y)->x+1/y))
end.
Результат
S=3.59773965714368
- 18.09.2018 23:01
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.