Вопрос по информатике:
Написать программу нахождения наибольшего значения их пяти переменных
- 22.03.2016 10:31
- Информатика
- remove_red_eye 14460
- thumb_up 27
Ответы и объяснения 2
begin
readln(a,b,c,d,e);
If (a>b) and (a>c) and (a>d) and (a>e) then max:=a;
If (b>a) and (b>c) and (b>d) and (b>e) then max:=b;
If (c>a) and (c>b) and (c>d) and (c>e) then max:=c;
If (d>a) and (d>b) and (d>c) and (d>e) then max:=d;
If (e>a) and (e>b) and (e>c) and (e>d) then max:=e;
Writeln(max);
End.
- 23.03.2016 13:30
- thumb_up 41
begin
writeln('a, b, c, d, e:');
readln(a,b,c,d,e);
If a>b then max:=a else max:=b;
If c>max then max:=c;
If d>max then max:=d;
If e>max then max:=e;
Writeln('max = ',max);
End.
Пример:
a, b, c, d, e:
8 5 2 9 4
max = 9
- 24.03.2016 21:58
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.