Вопрос по информатике:
Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6 и имеет 2 знака в дробной части.
- 03.04.2018 15:26
- Информатика
- remove_red_eye 10701
- thumb_up 17
Ответы и объяснения 2
uses crt;
var
i : real;
a : string;
begin
clrscr;
Randomize;
writeln ('Для вывода следующего числа нажмите Enter');
writeln ('Для выхода из программы введите 0 и нажмите Enter');
while (true) do
begin
i := random(101)/100+5; //Случайное число от 5.00 до 6.00 включительно
writeln (i:6:2);
readln (a);
if a='0' then exit;
end;
end.
- 04.04.2018 18:56
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.