Вопрос по информатике:
ДАЮ 60 БАЛЛОВ!! РЕШИТЕ НА PYTHON
СРОЧНО НУЖНА ПОМОЩЬ!!!
Вычислите N! ("эн-факториал") – произведение всех натуральных чисел от 1 до N ( N!=1∙2∙3∙…∙ N ).
Входные данные
Вводится единственное число N – натуральное, не превосходит 12.
Выходные данные
Выведите полученное значение N!
Примеры
входные данные
2
выходные данные
2
входные данные
3
выходные данные
6
- 14.11.2017 01:35
- Информатика
- remove_red_eye 11738
- thumb_up 43
Ответы и объяснения 1
program time;var n, factorial, i: integer;begin factorial := 1; readln(n); for i := 1 to n do begin factorial := factorial * i; end; writeln(factorial);end.
- 15.11.2017 08:15
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.