Вопрос по информатике:
С клавиатуры вводится два целых числа, обозначающих возраст человека и его пол (1 – мужской, 2 –женский). Составить программу, которая в зависимости от введенных данных определяет принадлежность человека к определенной группе: от 0 до 13 – мальчик (девочка); от 14 до 20 – юноша (девушка); от 21 до 70 – мужчина (женщина); более 70 – старец (старушка).
- 06.09.2017 21:28
- Информатика
- remove_red_eye 12789
- thumb_up 40
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var age:=ReadInteger('Введите возраст:');
var gender:=ReadInteger('Введите пол (1-М, 2-Ж):');
if gender=1 then
case age of
0..13:Writeln('Мальчик');
14..20:Writeln('Юноша');
21..70:Writeln('Мужчина');
else Writeln('Старец')
end
else
case age of
0..13:Writeln('Девочка');
14..20:Writeln('Девушка');
21..70:Writeln('Женщина');
else Writeln('Старушка')
end
end.
- 07.09.2017 09:30
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.