Вопрос по информатике:
Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3.Программа получает на выход целые числа. Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность ).Количество чисел не превышает 20. Введенные числа [-30;30]. Программа должна вывести одно число: количество четных чисел, кратных 3.
Буду признательна!
- 14.08.2018 12:55
- Информатика
- remove_red_eye 856
- thumb_up 19
Ответы и объяснения 1
const n=20;
var a: array [1..n] of integer;
i,k: integer;
begin
k:=0;
for i:=1 to n do
begin
write('введите ',i,' число: ');
readln(a[i]);
if (a[i]=0) or (a[i]=30) then break;
if (a[i] mod 2=0) and (a[i] mod 3=0) then k:=k+1;
end;
writeln('количество: ',k);
end.
- 15.08.2018 22:06
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.