Вопрос по информатике:
Задача 1.
Дан массив из 30 элементов, заполненный целыми случайными числами из диапазона от -15 до +50. Вычислить сумму всех элементов массива, определить количество элементов массива кратных 3. Исходный массив и результат подсчета(количество и сумма) вывести на экран.
Задача 2.
Упорядочить массив из 20 целых чисел по убыванию. Исходный и упорядоченный массив вывести на экран.
Задача 3.
Составьте программу, которая по фамилии, имени и отчеству человека выводит на экран фамилию и инициалы человека.
например, Иванов Петр Степанович должно получиться на экране Иванов П.С.
- 01.06.2018 11:04
- Информатика
- remove_red_eye 5982
- thumb_up 17
Ответы и объяснения 1
a: array [1..30] of integer;
i, s, k: integer;
beginfor i := 1 to 30 do//заполнение рандомными числами(от -15 до 50, включая и -15 и 50) массив
a[i] := random(-15, 50);
for i := 1 to 30 do//сумма элементов и подсчет кратных 3
begin
s := s + a[i];//сумма элементов
if a[i] mod 3 = 0 then//подсчет кол во кратных 3
k := k + 1;
end;
writeln('Исходный массив');
for i := 1 to 30 do
writeln('A[', i, '] = ', a[i]);
writeln('Сумма элементов массива: ', s);
writeln('Кратных 3: ', k);
end.
извини помог бы дальше но дела но вот подсказки:
2) метод пузырька посмотри
3) там через функцию поиска и удаления
если над у меня есть группа в вк называется просто программки если интересно можешь глянуть
- 02.06.2018 17:39
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.