Вопрос по информатике:
Напишите программу на pascal, вычисляющую факториал введенного числа n!!!
- 07.12.2017 17:55
- Информатика
- remove_red_eye 2932
- thumb_up 41
Ответы и объяснения 2
uses crt;
var n, i, s: integer;
begin
read(n);
s := 1;
for i := 1 to n do
s := s * i;
writeln(s);
end.
- 08.12.2017 10:26
- thumb_up 47
var
n : byte;
function fact (a: byte): uint64;
var pz : uint64;
i : byte;
begin
pz:=1;
for i:=1 to a do pz:=pz*i;
fact:=pz;
end;
begin
repeat
write ('Введите n : ');
readln (n);
until n in [0..20];
write ('n! = ', fact(n));
end.
- 09.12.2017 13:53
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.