Вопрос по информатике:
Пожалуйста помогите написать программу по информатики для решения задачи: В массиве рост юношей задан отрицательным числом, рост девушек положительным, определите отдельно средний рост юношей и девушек и можно это сделать как нибудь примерно так? program xxx; var M,D,i,ran:integer; a:array [1..10] of integer; begin for i:=1 to 10 do ran:=100-random(200)+1; for i:=1 to 10 do if a[i]<0 then M:=M+a[i] else D:=D+a[i]; write (M,' '); write (D,' ') end..
- 14.01.2018 22:58
- Информатика
- remove_red_eye 15983
- thumb_up 17
Ответы и объяснения 1
//PascalABC.NET 3.2 сборка 1318
Const
n=10;
Var
m,fm:real;
mc,fmc,i:integer;
val:array[1..n] of real;
begin
for i:=1 to n do
begin
readln(val[i]);
if val[i]>0 then
begin
inc(fmc);
fm+=val[i];
end
else
if val[i]<0 then
begin
inc(mc);
m+=abs(val[i]);
end
else
begin
writeln('Funny joke!(no)');
exit;
end;
end;
writeln('Male average=',m/mc);
writeln('Female average=',fm/fmc);
end.
- 15.01.2018 12:47
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.