Вопрос по информатике:
Очень нужно) Информатика, программирование на языке паскаль.
1.Введенную строку вывести в обратном порядке (с последней буквы начинается и первой заканчивается)
2.Напишите программу, которая определить какой символ A или B встречается чаще.
- 02.05.2018 02:51
- Информатика
- remove_red_eye 7034
- thumb_up 31
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
Writeln(s.Inverse)
end.
Пример
Я пишу программу на языке Паскаль
ьлаксаП екызя ан уммаргорп ушип Я
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Введите строку:');
Write('Введите два символа СЛИТНО для сравнения их частоты: ');
var ab:string;
Readln(ab);
var a:=ab[1];
var b:=ab[2];
var ka:=0;
var kb:=0;
for var i:=1 to s.Length do
if s[i]=a then ka+=1
else if s[i]=b then kb+=1;
if ka>kb then Writeln('Символ ',a,' встречается чаще, чем ',b)
else
if ka
if ka0 then Writeln('Символы ',a,' и ',b,' встречается одинаково')
else Writeln('Символы ',a,' и ',b,' отсутствуют')
end.
Пример
Введите строку: а роза упала на лапу азора
Введите два символа СЛИТНО для сравнения их частоты: ао
Символ а встречается чаще, чем о
- 04.05.2018 00:57
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.