Вопрос по информатике:
Даны два числа n и m. Создайте двумерный массив A[n][m], заполните его таблицей умножения A[i][j]=i*j и выведите на экран. При этом нельзя использовать вложенные циклы, все заполнение массива должно производиться одним циклом.
Входные данные
Программа получает на вход два числа n и m – количество строк и столбцов, соответственно.
Выходные данные
Программа должна вывести полученный массив. Числа разделяйте одним пробелом.
Примеры
входные данные
3 3
выходные данные
0 0 0
0 1 2
0 2 4
- 07.09.2017 17:13
- Информатика
- remove_red_eye 9639
- thumb_up 24
Ответы и объяснения 1
a:array of array of integer;
n,m,i:integer;
begin
writeln('n, m:');
readln(n,m);
SetLength(a,n);
for i:=0 to n-1 do
SetLength(a[i],m);
for i:=0 to n*m-1 do
a[i div m,i mod m]:=(i div m)*(i mod m);
for i:=0 to n*m-1 do
begin
write(a[i div m,i mod m]:3);
if (i+1) mod m = 0 then writeln;
end;
end.
Пример:
n, m:
4 5
0 0 0 0 0
0 1 2 3 4
0 2 4 6 8
0 3 6 9 12
- 08.09.2017 09:02
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.