Вопрос по информатике:
Написать программу перевода из десятичной системы счисления в двоичную при помощи функций пользователя. Паскаль(Функции пользователя).
- 20.10.2017 04:09
- Информатика
- remove_red_eye 8156
- thumb_up 40
Ответы и объяснения 1
var n: integer;
function per(n: integer ): integer;
var
a: array[1..500] of integer;
i,c:integer;
begin
c:= 0;
repeat
c:= c + 1;
a[c]:= n mod 2;
n:= n div 2;
until n = 0;
for i:= c downto 1 do
write(a[i]);
end;
begin
write('введите число: ');
readln(n);
per(n);
end.
- 21.10.2017 16:59
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.