Вопрос по информатике:
Даны координаты противопложных вершин прямоугольника х1 у1 х2 у2 стороны прямоугольника парралельны осям координата координат* составьте программу вычесления периметра и площади прямоугольника
- 12.02.2018 14:21
- Информатика
- remove_red_eye 10181
- thumb_up 48
Ответы и объяснения 1
var x1,x2,x3,y1,y2,y3,ax,bx,ay,by,a,b,p,s:integer;
begin
readln(x1); readln(y1); readln(x2); readln(y2);
x3:=x1; y3:=y2; //координаты 3 точки
ax:=x1-x3; ay:=y1-y3; bx:=x2-x3; by:=y2-y3; //координаты направляющих векторов
a:=sqrt(sqr(ax)+sqr(ay)); //длинна вектора
b:=sqrt(sqr(bx)+sqr(by)); //длинна вектора
p:=2*(a+b); //периметр
s:=a*b; //площадь
writeln(p);
writeln(s);
end.
- 13.02.2018 03:58
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.