Вопрос по информатике:
Составить программу , которая вычесляет произведение сумму первых 137 натуральных чесел (параметром цикла является переменная а, а произведение хранится в переменой p)
плиз решите я на уроке сижу!!!
- 12.09.2015 17:35
- Информатика
- remove_red_eye 12489
- thumb_up 14
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
var p:=Range(1,137);
Writeln('Сумма чисел от 1 до 137 равна ',p.Sum);
Writeln('Их произведение равно ',p.Aggregate(BigInteger(1),(x,y)->x*y))
end.
Результат
Сумма чисел от 1 до 137 равна 9453
Их произведение равно 5012888748274991661034926292112253883237205694398754483388962668892510972746226260034675717797072343372830591567227826571884373881355612819314826377917827129740056802397016509378163883274055583382110208000000000000000000000000000000000
- 14.09.2015 18:22
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.