Вопрос по информатике:
Даны два натуральных числа. Определить, значение большего из них и во сколько раз. Если числа равны, то вывести "EQUALS".
Входные данные:
Во входном потоке заданы два целых числа, перечисленные через пробел.Значения каждого из них не превышают 32000
пример входного файла (input.txt)
4 8
Выходные данные:
В выходной поток ввести два числа через пробел: целое и вещественное с точностью три знака после запятой или строку EQUALS
Пример выходного файла (output.txt)
8 2.000
- 20.02.2018 18:19
- Информатика
- remove_red_eye 18211
- thumb_up 48
Ответы и объяснения 1
var
a,b: integer;
c: real;
begin
readln(a,b);
if a>b then
begin
c:=a/b;
write(a,c:6:3)
end else
if a begin
c:=b/a;
write(b,c:6:3)
end else
write('EQUALS');
end.
- 21.02.2018 21:01
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.