Вопрос по информатике:
Написать программу проверки возрастного ограничения в кинотеатрах
- 06.01.2018 19:26
- Информатика
- remove_red_eye 16178
- thumb_up 25
Ответы и объяснения 1
type
film = record
name : string[20];
age : byte;
end;
var
a: array of film;
n, i: byte;
begin
write ('Введите кол-во фильмов: ');
readln (n);
setLength (a, n);
for i:=0 to n-1 do
begin
write ('Введите название фильма ', i+1, ': ');
readln (a[i].name);
write ('Введите возрастное ограничение фильма ', i+1, ': ');
readln (a[i].age);
end;
writeln ('Введите возраст зрителя: ');
readln (n);
writeln ('-------------------------');
for i:=0 to length (a)-1 do
begin
if n>a[i].age then write ('Этот зритель может ') else write ('Этот зритель не может ');
writeln ('пойти на фильм "', a[i].name, '"');
end;
end.
- 07.01.2018 16:27
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.