Вопрос по информатике:
Задача по информатике написать программу в которой будет вычитаться из числа 1000 числа,введённые пользователем с клавиатуры до тех пор, пока разность не станет меньше 0. примечание применить цикл REPEAT,UNTIL помогите пожалуйста буду благодарен
- 10.02.2018 00:24
- Информатика
- remove_red_eye 17015
- thumb_up 8
Ответы и объяснения 1
begin
var t:=1000;
var k:integer;
repeat
k:=ReadInteger('->');
t-=k
until t<0;
Writeln('Всё...')
end.
Пример
-> 453
-> 216
-> 39
-> 64
-> 312
Всё...
Решение для "древних паскалей"
var
k,t:integer;
begin
t:=1000;
repeat
Write('->'); Read(k);
t:=t-k
until t<0;
Writeln('Всё...')
end.
- 11.02.2018 20:29
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.