Вопрос по информатике:
Написать программу,которая проверяет,есть ли во введённом с клавиатуры массиве элементы с одинаковым значением
- 18.02.2018 01:25
- Информатика
- remove_red_eye 1262
- thumb_up 49
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger('Вводите:',ReadInteger('n='));
if a.Count>a.ToHashSet.Count then
Writeln('Есть одинаковые элементы')
else Writeln('Все элементы различны')
end.
Примеры
n= 4
Вводите: 4 2 5 2
Есть одинаковые элементы
n= 4
Вводите: 5 8 -3 0
Все элементы различны
- 19.02.2018 06:17
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.