Вопрос по информатике:
Составить программу в паскале , которая в массиве из десяти целых чисел считает среднее арифметическое отрицательных.
- 09.11.2015 23:57
- Информатика
- remove_red_eye 19962
- thumb_up 13
Ответы и объяснения 2
var a:array[1..n] of integer;
i,s,k:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(51)-25;
write(a[i]:4);
end;
writeln;
s:=0; k:=0;
for i:=1 to n do
if a[i]<0 then begin s:=s+a[i]; k:=k+1; end;
writeln('s = ',s,' k = ',k);
if k>0
then writeln('Среднее арифметическое отрицательных = ',s/k)
else writeln('Отрицательных нет');
end.
Пример:
Массив A:
-11 11 13 9 -11 -2 18 -18 3 -14
s = -56 k = 5
Среднее арифметическое отрицательных = -11.2
- 01.01.1970 00:00
- thumb_up 11
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger('Вводите:',10);
Writeln('Ср.арифм. отрицательных чисел ',a.Where(x->x<0).Average)
end.
Пример
Вводите: 5 -3 2 8 11 21 -42 16 0 5
Ср.арифм. отрицательных чисел -22.5
- 01.01.1970 00:00
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.