Вопрос по информатике:
Написать программу, определяющую (отвечающею на вопрос) - больше ли числа х сумма цифр введённого числа
- 03.01.2018 12:50
- Информатика
- remove_red_eye 2463
- thumb_up 51
Ответы и объяснения 2
begin
write('a = ');
readln(a);
write('x = ');
readln(x);
b:=a;
s:=0;
while b>0 do
begin
s:=s+b mod 10;
b:=b div 10;
end;
writeln('s = ',s);
if s>x
then writeln('Сумма цифр больше ',x)
else writeln('Сумма цифр не больше ',x);
end.
Пример:
a = 31854
x = 15
s = 21
Сумма цифр больше 15
- 05.01.2018 00:39
- thumb_up 7
#include
using namespace std;
int main() {
int a,x,s=0;
cin >> a >> x;
for(;abs(a)>0;s+=abs(a)%10,a/=10);
cout < x ? "more" : "not more") << endl;
}
- 05.01.2018 17:44
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.