Вопрос по информатике:
Дано натуральное число N,последовательность целых чисел A1,A2,...An.Составить программу ,которая последовательно прибавляя членв последовательности, выводит результат,когда сумма впервые превышает число N. Если сумма всех членов последовательности не превышает число N, выведите об этом сообщение
- 15.12.2015 03:06
- Информатика
- remove_red_eye 6840
- thumb_up 37
Ответы и объяснения 1
n = 5;
var
arr: array [1..n] of integer;
i, N1, sum: integer;
begin
write('N = ');
readln(N1);
for i := 1 to n do
begin
write('A[', i, '] = ');
readln(arr[i]);
end;
i := 1;
sum := 0;
while (sum <= N1) and (i <= n) do
begin
sum := sum + arr[i];
i := i + 1;
end;
if sum > N1 then
writeln(sum)
else
writeln('Summa not grether then N');
end.
- 16.12.2015 14:23
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.