Вопрос по информатике:
Pascal Составить программу поиска трех значных чисел, сумма цифр которого равна N
- 18.02.2018 01:32
- Информатика
- remove_red_eye 9681
- thumb_up 16
Ответы и объяснения 1
i, n, s, k: integer;
begin
readln(n);
for i := 100 to 999 do
begin
s := 0; k := i;
while k > 0 do
begin
s := s + k mod 10;
k := k div 10;
end;
if s = n then
writeln(i);
end;
end.
- 19.02.2018 23:10
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.