Вопрос по информатике:
Составить программу вычисления и печати суммы всех членов последовательности, меньших 0.8:
S=1/3+2/4+3/5.....+i/(i+2)
- 03.12.2017 05:07
- Информатика
- remove_red_eye 14814
- thumb_up 14
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
var i:=1;
var s:=0.0;
while true do begin
var t:=i/(i+2);
if t>=0.8 then break;
s+=t; i+=1
end;
Writeln('s=',s)
end.
Результат
s=4.34206349206349
- 04.12.2017 13:11
- thumb_up 20
using namepspace std;
int main() {
for(int i = 1, s = 0; (i/i+2) < 0.8; s+=(i/i+2), i++);
cout << s << endl;
}
- 05.12.2017 23:41
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.