Вопрос по информатике:
Дана последовательность n элементов. Написать программу которая прдсчитает сумму элементов этой последовательности.
- 27.11.2017 19:29
- Информатика
- remove_red_eye 9409
- thumb_up 15
Ответы и объяснения 1
var i,n,s: integer;
a: array[1..m] of integer;
begin
write('размер массива: '); readln(n);
randomize;
s:=0;
writeln('исходный массив: ');
for i:=1 to n do
begin
a[i]:=random(-50,50);
write(a[i],' ');
s:=s+a[i];
end;
writeln;
writeln('сумма элементов: ',s);
end.
размер массива: 15
исходный массив:
20 -20 8 -8 25 42 1 38 -31 17 30 2 -6 -43 35
сумма элементов: 110
- 28.11.2017 16:35
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.