Вопрос по информатике:
Дан вектор имеющий n (1<=n<=100)целых элементов. напишите программу которая находит среднее арифметическое значение элементов, стоящих на нечётных позициях
- 06.03.2018 00:07
- Информатика
- remove_red_eye 5520
- thumb_up 13
Ответы и объяснения 1
#include
using namespace std;
int main() {
unsigned short int n;
cout << "n = ";
cin >> n;
vector a;
int in,
avg,
s = 0,
c = 0;
for (int i = 0; i < n; ++i) {
cout << "a[" << i << "] = ";
cin >> in;
a.insert(a.end(), in);
if (i % 2 == 1) {
s += a.back();
c++;
}
}
avg = (int) s / c;
cout << "Среднее арифметическое элементов на нечётных позициях: "
<< avg;
return 0;
}
- 06.03.2018 13:40
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.