Вопрос по информатике:
Напишите программу которая удаляет из заданного текста комбинацию "ем" (земля-планета солнечной системы)
- 15.07.2017 00:18
- Информатика
- remove_red_eye 10423
- thumb_up 45
Ответы и объяснения 2
const
RM = 'ем';
var
c, n: char;
seq: boolean := False;
s: string := 'Земля - планета солнечной системы';
begin
writeln(s);
for var i := 1 to (length(s) -1) do
begin
c := s[i];
n := s[i+1];
if seq = True then
begin
seq := False;
continue;
end;
if (c = RM[1]) and (n = RM[2]) then
begin
seq := True;
continue;
end
else
begin
seq := False;
write(c);
end;
end;
write(s[length(s)]);
end.
- 15.07.2017 14:38
- thumb_up 38
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
s:=s.Replace('ем',''); s.Println
end.
Пример
> земля- планета солнечной системы
зля- планета солнечной систы
- 16.07.2017 03:35
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.