Вопрос по информатике:
Надо написать программу
Вычислите N! ("эн-факториал") – произведение всех натуральных чисел от 1 до N ( N!=1∙2∙3∙…∙ N ).
Входные данные
Вводится единственное число N – натуральное, не превосходит 12.
Выходные данные
Выведите полученное значение N!
Примеры
входные данные
2
выходные данные
2
входные данные
3
выходные данные
6 (На Паскале) Буду благодарен
- 11.11.2015 18:08
- Информатика
- remove_red_eye 12303
- thumb_up 13
Ответы и объяснения 2
var
n, f, i: integer;
begin
f := 1;
readln(n);
for i := 2 to n do
f := f * i;
writeln(f);
end.
- 12.11.2015 02:31
- thumb_up 37
begin
readln(n);
b:=1;
for i := 1 to n do
b:=b*i;
writeln(b);
end.
Входные данные подставлять в переменную n
- 13.11.2015 18:17
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.