Вопрос по информатике:
Написать программу которая запросит длинны трёх сторон треугольника. Проверить возможность его сущ. и в предположенном результате найдёт и выведет на экран площадь один. Ребята!!!! Спасайте кто может!!!!!
- 08.06.2018 19:40
- Информатика
- remove_red_eye 8253
- thumb_up 35
Ответы и объяснения 1
a,b,c{длины сторон}, S{площадь тр.}, p{полупериметр}:double;
begin
writeln('Введите стороны треугольника:');
readln(a,b,c);
if (a>=b+c) or (b>=a+c) or (c>=a+b) then
writeln ('Такого треугольника не существует')
else begin
p:=(a+b+c)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c)); {вычисляем S тр. по формуле Герона}
writeln ('Такой треугольник существует, его S = ', S, 'ед.');
end;
end.
- 09.06.2018 02:00
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.