Вопрос по информатике:
Пожалуйста помогите составить программу(с++) и блок-схему
Дан размер файла в байтах. Используя операцию деления нацело, найти количество полных килобайтов, которые занимает данный файл (1 килобайт = 1024 байта).
- 16.02.2018 17:18
- Информатика
- remove_red_eye 9570
- thumb_up 49
Ответы и объяснения 1
#include
using namespace std;
int main() {
int b, k;
cin >> b;
k = (b-1)/1024+1;
cout << "k = " << k << "\n";
return 0;
}
Пример:
2050
k = 3
- 17.02.2018 01:07
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.