Вопрос по информатике:
В книге на одной странице помещается K строк. Таким образом, на 1-й странице печатаются строки с 1-й по K-ю, на второй — с (K+1)-й по (2∙K)-ю и т.д. Напишите программу, которая по номеру строки в тексте определяет номер страницы, на которой будет напечатана эта строка, и порядковый номер этой строки на странице.
- 24.03.2017 05:56
- Информатика
- remove_red_eye 11376
- thumb_up 35
Ответы и объяснения 1
var
n, k, fullPages, restLines: integer;
begin
write('Номер строки: ');
readln(n);
write('Строк на странице: ');
readln(k);
fullPages := (n - 1) div k;
restLines := (n - 1) mod k;
writeln('Страница: ', fullPages + 1, ', строка: ', restLines + 1);
end.
- 25.03.2017 00:17
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.