Вопрос по информатике:
Написать программу для паскаль! Срочно, помогите, пожалуйста!
Дано натуральное число. Установить, является ли последовательность его цифр, при просмотре их слева направо, упорядоченной по убыванию.
- 07.09.2017 02:41
- Информатика
- remove_red_eye 1986
- thumb_up 39
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin;
var s:=ReadInteger('n=').ToString;
If s.Length(s.Distinct.Count) then Writeln('не является')
else
if s=s.ToCharArray.SortedDescending.JoinIntoString('')
then Writeln('является') else Writeln('не является')
end.
Примеры
n= 9875431
является
n= 9753321
не является
n= 9763421
не является
Замечание: учтено, что упорядоченность должна быть по убыванию а не по невозрастанию. т.е. нельзя, чтобы попадались две одинаковые цифры.
- 08.09.2017 15:13
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.