Вопрос по информатике:
Паскаль
Помогите доделать задачу
Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.
Входные данные
Программа получает на вход три натуральных числа: x, p, y.
Выходные данные
Программа должна вывести одно целое число.
program u1;
var
x, p ,s,n: integer;
y:real;
begin
read(x);
read(p);
read(y);
s:=0;
s:= x +(x*p)div 100;
n:= 1;
while (s < y) do
begin
s := s +((s*p)div 100);
n:= n + 1;
end;
writeln (n);
readln;
end.
Здесь где-то есть недоработка.
- 05.11.2017 07:34
- Информатика
- remove_red_eye 1338
- thumb_up 31
Ответы и объяснения 1
var
x, p ,y, s, n: integer;
begin
readln(x,p,y);
s:=x;
n:= 0;
while (s < y) do
begin
s := s+trunc((s*p)/100);
n:= n+1;
end;
writeln(n);
end.
Пример:
100 10 500
18
- 06.11.2017 10:53
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.